
 
 

 

 

User’s Manual 
BASICS 

Welcome to MobiSystems® OfficeSuite! 

OfficeSuite is a complete mobile office solution, allowing you to create, view and edit 
Microsoft® Word, Excel and PowerPoint files away from your office. With the advanced 
editing features you can modify documents on-the-go and save them in their original format 
- DOC, DOCX, DOCM, RTF, ODT, TXT, XLS, XLSX, XLM, ODS, CSV, PPT, PPTX, PPS, PPSX, PPTM, 
PPSM and ODP - just ready to be used back on your desktop computer. You are also able to 
open Adobe PDF, EML, LOG and ZIP files and attachments.  

OFFICESUITE MODULES 

OfficeSuite is a group of applications sharing the same user interface, look and feel, and a 
common File browser. Each separate module in OfficeSuite supports different Microsoft® 
Office file formats: Document Editor for Microsoft® Word, Spreadsheet Editor for 
Microsoft® Excel and Presentation Editor for Microsoft® PowerPoint. PDF module is also 
included to allow users to open the commonly used PDF files and attachments. Email reader 
module allows you to open and view EML files and attachments. 

SUPPORTED FORMATS 

The file formats supported by OfficeSuite are:  

 
Microsoft® Word 97-2003 text documents. 

 
Microsoft® Word 2007 text documents. 

 
Microsoft® Word 2010 text documents. 

 
Microsoft® Word text documents with macros. 

 
Rich Text Format. 

 
Open Office text documents. 



 
 

 

 

 

the commonly used TXT format for compatibility with third-party desktop 
programs. 

 

the commonly used LOG format for compatibility with third-party desktop 
programs. 

OfficeSuite Spreadsheet Editor: 

 
Microsoft® Excel 97-2003 documents.  

 
Microsoft® Excel 2007 documents.  

 
Microsoft® Excel 2010 documents.  

 
Microsoft® Excel documents with macros.  

 
Open Office Spreadsheet documents.  

 

CSV (comma separated) format ensures the compatibility with third-party 
desktop programs. 

The PowerPoint file formats that OfficeSuite opens and allows to be edited are:  

  
Microsoft® PowerPoint® 97-2003 documents. 

  
Microsoft® PowerPoint® 2007 documents. 

  
Microsoft® PowerPoint® 2010 documents. 

  
Microsoft® PowerPoint® documents with macros. 

 
 Open Office Presentation documents. 

OfficeSuite includes the OfficeSuite PDF Viewer which allows you to open Adobe® 

files. 

With OfficeSuite you are also able to open and files and attachments. 

CONTROLS AND NAVIGATION 

OfficeSuite has several different ways to help you access and manage your files:  

 Menus, Toolbars and Action Bar - in the File Browser the menu items are accessible 
through the virtual onscreen buttons at the bottom of the screen. When a document, 
spreadsheet or presentation is being edited you can access all menu options from the 



 
 

 

 

toolbar in each module. The Action bar on the top of the screen offers quick access to 
all menu tabs.  

 Side bar - the side bar is available in the File Browser and gives quick access to 
different folders and remote third party cloud services. To show / hide the side bar, 

slide the screen right / left. Alternatively, press the button at the top left-hand 
corner of the screen to open the side bar. The side bar in not available on tablets 
where the larger display size allows dual pane user interface in the File Browser.  

 Context menus - the context menus appear when you long press an object. They offer 
quick access to frequently used operations for the selected object.  

 Toolbars - The File browser, the Document module and the Spreadsheet module offer 
useful toolbars at the top of the screen. 

 Popup toolbars - In the Document Editor, in the Spreadsheet Editor and in the 
Powerpoint Editor there are context popup toolbars for quick access to most 
frequently used operations over different objects. Long-press an object to open the 
popup menu. 

OPENING DOCUMENTS 

OfficeSuite allows you to open local or remote files, attachments that you received in your 
email client or files downloaded from a web browser:  

 E-mail attachments  

When you receive an email attachment in one of the supported file formats, press 
View on the Attachment button and select Complete Action Using OfficeSuite. 

 Through OfficeSuite File Browser  

Open OfficeSuite and use the built-in File Browser to navigate to the desired file and 
open it. Various supported file formats are listed with different icons. Recent files and 
My documents shortcuts in the file browser offer quick access to recently used files or 
to your designated document folder. 

 Through web browser  

While browsing the web you might come across document files. Download the file and 
select OfficeSuite to open it when prompted. 

 Remote files  

OfficeSuite allows you to access your third party cloud storage accounts and files. To do so, 
use Remote files in File Browser side bar on Android phones or the left pane on tablets. Then 
you will be allowed to select among Google Drive, Dropbox, Box, SygarSync and OneDrive 

OFFICESUITE PREMIUM 

A number of advanced editing features are available in OfficeSuite Premium only as in-app 
purchase on subscription base. The premium features are: 

 Ad Free 

 Export to PDF 

 Print 



 
 

 

 

 Open Office format support 

 Standard Font Pack 

 Format Painter in Word documents 

 Save with password 

 Camera picture insertion 

 Word to PDF conversion 

 Insert filters in Excel 

 Insert conditional formatting 

 Define names in spreadsheets 

 Export picture from file (Save Picture) Excel 

 Edit charts in Excel files  

 Save as CSV 

 Edit transitions in PowerPoint 

 Export PDF to Word, Excel and ePub 

 Microsoft Compatibility Font Pack 

 New! Track changes 

 New! PDF files protection 

 QuickWrite predictive keyboard 

 QuickSpell spell check 

 New! PhotoSuite 3 image editor 

 QuickPDF Scanner Premium 

 Priority support 

THE FILE BROWSER IN OFFICESUITE 

Upon starting the application, the OfficeSuite File Browser will open. The File Browser gives 
you access to your documents, folders and remote cloud accounts by Google Drive, 
DropBox, Box, SugarSync and OneDrive. On Android 3.0 or higher tablets, the file browser 
provides a split panel interface.



 
 

 

 

MANAGING FILES AND FOLDERS 

The File Browser is organized in several useful shortcuts providing quick access to local files, 
remotely stored files or to designated document folders:  

 
Home - the home screen in OfficeSuite.  

 
Recent files - a folder with the last used files.  

 

Templates - template Word, Excel and PowerPoint documents ready to be 
modified and used.  

 

My documents - the default document folder on you device. Initially you will be 
able to select it. 

 
Internal storage - you can browse all local files on memory cards. 

 

Remote files - access to your Google Drive, DropBox, Box, SugarSync or OneDrive 
account. 

The File Browser provides basic operations to help you manage your files and folders. A long 
tap on a file from the file list will open the File Options context menu. You can do the 
following operations: 

 Rename a file.  

 Delete a file.  

 Send via Wi-Fi Direct.  

 Send file via Bluetooth, email client, or to a remote cloud account. 

 Zip and send a file via Bluetooth, email client, or to a remote cloud account. 

 Print a file with Google Cloud Print or with a 3rd party print application(available in 
OfficeSuite Premium with in-app purchase) 

 View the properties of a file, such as file Name, Type, File Size, Path to the file, and 
Date modified. 

You can rename and delete folders via the context menu. To create a new folder, select 

 from the toolbar. 

CREATING DOCUMENTS 

OfficeSuite Professional allows you to create new office documents. To do so, select 

from the toolbar. You will be prompted to select the type of document to be created - Word 
document, Excel workbook or PowerPoint presentation. You also have the option to use 
some of the templates offered by OfficeSuite.  

 

 



 
 

 

 

MOVING FILES 

You can move files and folders through Copy/Cut and Paste. Check the checkbox next to the 

files/folders you want to move and choose Cut or Copy from the toolbar. 

Browse to the destination folder and choose Edit  Paste. 

SORTING FILES 

To sort files, select from OfficeSuite toolbar. Choose the criteria by which you want to 
sort the files:  

 
Name 

 
Type 

 
Size 

 
Date modified 

FINDING FILES 

To find a file or folder, select from the toolbar. Type in the file name, part of the name 
or even just the file extension.  

SHARING DOCUMENTS 

OfficeSuite allows you to share your documents directly from the file browser by sending 
them to an email recipient, to another device via Bluetooth, or by uploading them to an 
existing Google Drive, DropBox, Box, SugarSync or OneDrive account. 

 To send a file via email or Bluetooth, tap and hold on the file until the File options 
menu appears and choose Send file. You can chose to send it either via the email 
client or via Bluetooth. The file will be sent as an attachment to a new email in the 
program that you have selected to use.  

 You can compress a file before sending it to reduce its size. To do so, select Zip & 
Send file in the File options menu that appears when you tap and hold on a file.  

 You can send files via Wi-Fi Direct. The feature is accessible via Send file in the 

context menu or from the toolbar. 



 
 

 

 

USING DICTIONARIES 

OfficeSuite allows you to look up the meanings of selected words in text documents in a 
dictionary or reference book. More than one dictionary can be installed. To download 
dictionaries to use with OfficeSuite, go to www.mobisystems.com/mobile. You can choose 
among over 400 free and commercial dictionaries and reference books. 

THE TEXT EDITOR IN OFFICESUITE 

OfficeSuite supports viewing and editing of Microsoft Word DOC, DOCX and DOCM files, as 
well as RTF, TXT and Open Office ODT files.  

READING AND NAVIGATION 

When a document is opened, the file contents will be loaded sequentially. You can easily 
scroll within the document in order to read it. OfficeSuite also provides several options for 
easy navigation in the document accessible through the View tab:  

 Web view and Page view  - switch easily between the two modes. In Web 
view the reading space is fitted to the screen while in Page view you can see the 
original page layout.  

To navigate to the top and bottom of the document use the Go to top and Go to 

bottom buttons.  

WORKING WITH BOOKMARKS AND HYPERLINKS  

Bookmarks 

To insert a Bookmark within a document tap where you wish to place the bookmark and 

then go to the Insert tab. Tap on the Bookmark  button and enter a name for the 

bookmark. To access the bookmark go to the View tab and tap on Go to bookmark 

Choose the bookmark you want to go to from the list of available bookmarks. To delete a 

bookmark tap on Delete bookmark and choose the bookmark you want to delete from 

the next screen.  

 

http://www.mobisystems.com/mobile/android/


 
 

 

 

Hyperlinks 

You can set hyperlinks to web addresses or to a Bookmark within a document. To do that go 

to the Insert tab and tap on the Hyperlink button and either type in the URL or choose 

a Bookmark to which you want to link. To follow the hyperlink long tap on it and choose the 

follow hyperlink button from the popup menu.  

ZOOM 

You can select the most convenient zoom value for reading from the Zoom button 

under the View tab. Available Zoom values are: Fit width, Fit, Fit two pages and percentage 

values. You can also Zoom one page at a time , Zoom two pages  or Zoom width 

which will fit the page width to the screen. To use the entire screen area to view a 

document you can use the Full screen . To exit Full screen use the standard back 

button of the device.  

WORKING WITH FILES  

You can create a new file by tapping on the New button under the File tab. OfficeSuite 

also offers templates of different types of documents which you can access from the 

Templates button. To open an existing file choose Open - from the File tab and 

browse to the file or go to the OfficeSuite file browser and tap on the file. To open recently 

viewed files tap on Open recent - or go to the Side bar and tap on the Recent files 

option.  

When you save a file you can save it to the internal storage, to the SD card, to a remote 
account or in another file format.  

To save a file tap on the File tab and then on the Save  button. You will be prompted to 
choose a format from the available formats as well as set the file name and choose the save 
location. You can save files in the same format they are originally saved or you can choose a 

preferred format. To change the format of an existing file tap on the Save as  button 
under the File tab. 



 
 

 

 

OfficeSuite allows you to change the file name from the OfficeSuite browser. To do that long 
hold on the file and choose Rename from the popup menu. In the next dialog enter the 
name you want to use.  

To delete a single file or a multitude of files you can long hold on the file and choose Delete 
from the context menu or check the checkbox next to the file(s) and choose delete from the 
toolbar  

If you want to save files so they cannot be modified you can do that through the Export to 

PDF feature located under the File tab. 

FILE SECURITY 

You can use passwords to stop other people from opening or modifying your files. To protect 

your files go to the File tab and tap on the Protect button. Enter a password in the 

Protect dialog. You will need this password the next time you open the document. To 

remove a password tap on the Protect button and delete the password you have set. Please 

note that if you forget your password OfficeSuite cannot retrieve it for you.  

PRINTING AND SHARING 

Printing 

In OfficeSuite you can print files over a wireless printer directly from the device. The print 

option is available under the File tab. To print a document tap on the Print button and 

select the printer you want to use. To add a new printer follow the instructions under "Add 

printer".  

Sharing 

OfficeSuite gives you the opportunity to share your files through a number of cloud services 

such as: Google Drive, Dropbox, Box, SugarSync and OneDrive. You can upload a file to a 

Remote account through Copy/Cut and Paste. To do that check the checkbox next to the file 

in the OfficeSuite file browser and choose Copy or Cut from the toolbar. Go to 

Side bar->Remote files and add your remote account. Once you are in the remote account 

you can paste the file from Edit -> Paste.  



 
 

 

 

You can also send files as email attachments or via Wi-Fi Direct from the OfficeSuite file 

browser. Check the checkbox next to the file to select it and tap on the Share button 
from the toolbar. Choose the file sharing option you want to use.  

WORKING WITH TEXT 

Text selection 

To select text, double-tap where you want to start the selection. The marked text will be 

highlighted. Fine selectors will appear that will allow you to extend or refine your choice. Tap 

and drag either of the selectors until you highlight the exact text that you need.  

Cut, Copy, Paste and Move text and formatting 

OfficeSuite Pro allows you to cut, copy and paste text selection to other places in the current 

document, other documents or external applications on your device. To do so: 

1. Select the text. 

2. A popup toolbar will appear that will allow you to Cut or Copy the 
selection.  

3. Go to the place where you want to paste the text and select Paste from the 
popup toolbar.  

You can also move text from one place to another in the file you are working with. To do 
that select the text and long hold on it until a popup dialog "Drag to move selection" 
appears. Drag the cursor to where you want to move the selection and the text will be 
moved. 

OfficeSuite also allows you to copy formatting you already have in the document and apply it 

to another section of the document. To do that select the text with the formatting you want 

to use and go to Home tab. Tap on the Format painter button so it becomes 

highlighted. Select the text you want to format and tap on Paste style . The text will be 

formatted.  



 
 

 

 

Undo / Redo 

In OfficeSuite you are able to undo and redo the last operations that you have performed. To 

do so, use the Undo or Redo icons from the action bar. 

Find and Replace Text 

You can find or replace text through Find & Replace button from the Home menu . To 

start the search, place the cursor at the beginning of the text and tap on . Enter the 
word/phrase that you want to search for and tap on Find/Replace or Replace all depending 
on what you want to do. The results will be highlighted or replaced in the text.  

EDITING FEATURES 

Text, Paragraph and Lists Formatting 

You can access to the most frequently used font and paragraph formatting options such as 
font size and type, format painter, bold, italic, underline, paragraph alignment and indent, 
and font color through the Home tab in the document module. The highlighted toolbar icons 
show the formatting currently applied to the selected text. You can format selected text by 
tapping the desired toolbar icons.  

For more advanced formatting use the Format tab. 

Formatting text 

In order to format selected texts or lists you can use the Format tab. To access the advanced 

text formatting items tap on the Font button You are able to format font types, sizes 
and styles, colors and effects and character spacing. 

You can also set different paragraph formatting. To choose from the available formatting 

options tap on the Paragraph button. From the paragraph dialog you are able to 
choose alignment, indents, spacing and line spacing.  

You can show or hide all formatting symbols used in the document through the Formatting 

symbols  button which is accessible through both the Home and the Format tabs.  

For better visualization and organization of the text you can insert bullets, numbered or 
multilevel lists and adjust the indent, line spacing, margins and page orientation in the 
document. These options are available under the Home and the Format tabs.  



 
 

 

 

If you want to add explanations in your document you can also insert new and edit existing 

comments. To insert a comment tap on the Comment button under the Insert tab . 
The text where you inserted the comment is highlighted in red. To access the comment long 

hold on the highlighted text and tap on Alternatively, tap on Edit  comment.  

To scribble or make free hand drawing you can use the Free hand drawing button. 
under the Insert tab 

Tap on and start drawing. If you raise your hand from the screen and stop drawing the 

free and drawing will be disabled and if you want to continue drawing you will have to tap 

on the Free hand drawing button again.  

Inserting objects 

OfficeSuite allows you to create and modify different embedded objects such as tables, 
shapes, hyperlinks, bookmarks, comments, footnotes, endnotes and images. 

You are able to insert new objects via the Insert tab: 

1. Place the cursor where you want to insert the object.  
2. Select the type of object you would like to insert from the toolbar: 

 Insert picture - You will be allowed to select a picture via external software. When 
the image is inserted you can:  

 drag it to the desired position 

 resize it by holding on one of the blue dots from the frame and dragging in the 
desired direction 

 rotate it to an angle of your choice  

 or delete it by selecting the delete icon at the top left hand corner of the screen 

 Camera picture 

 Free hand draw 

 Shapes 

 Hyperlink  

 Bookmark 

 Page Break 

 Comment 

 Footnote 

 Endnote 

3. Specify the properties for the selected object when prompted. 



 
 

 

 

Spell checking, Word count, Track changes 

In OfficeSuite you can check the document spelling, choose spelling languages, count the 

number of characters and note/detect changes made to the document.  

To check the document spelling place the cursor at the beginning of the document and tap 

on the Check spelling button available from the Review tab . OfficeSuite finds the 
misspelled word and offers suggestions to correct it. You can add the word to the spelling 

dictionary by tapping on and then on Add to dictionary at the bottom of the screen. 
You can change the spelling language from the drop-down list next to Add to dictionary.  

You can count the number of words, characters, spaces or sections in selected text or in the 

whole document through the Word count button under the Review tab .  

To note or detect any changes made to the document you can use the Track changes 
feature. Note that in order to view changes Track changes has to be enabled prior to making 

the changes. Under the Review tab tap on this button to activate track changes. When 
the track changes feature is active you can view all changes that you make to the document. 
The highlighted track changes button indicates that Track changes is active. If you want to 
disable it tap on the highlighted button. You can use the following Track changes options:  

 Merged view - this option shows the final changes (Final view), the document 
without changes (Original view) and the marked changes made to the document 
(Merged view)  

 Accept changes and Reject changes allow you to accept or reject the 
changes in the document. 

 Previous change and Next change allow you to go to the previous and 
next change in the document.  

CONTEXT MENUS, KEYBOARD SHORTCUTS, POPUP TOOLBARS, TOOLBARS, ACTION MENU 

OfficeSuite provides quick access to some commonly used operations through:  

 Context menus - Press and hold on the desired place in order to open the context 
menu. 

 Popup toolbars - When you select an object the popup toolbar will shortly appear for a 
period of time allowing you to make some basic formatting. 



 
 

 

 

For devices with keyboards OfficeSuite supports the following shortcuts: 

 Menu + x - Cut  

 Menu + c - Copy 

 Menu + v - Paste 

 Menu + z - Undo 

 Menu + y - Redo 

 Menu + a - Select all 

 Menu + s - Save 

USING DICTIONARIES TO LOOK UP WORDS 

OfficeSuite allows you to look up the meanings of selected words in a dictionary or reference 
book. This feature is only available in text documents. The dictionaries have to be installed 
on your device beforehand. To download and install dictionaries, go to MobiSystems web 
site http://www.mobisystems.com/mobile/android/category/dictionaries/. 

To check the meaning of a word, long tap on the screen until appears. Select a 
dictionary from the list of installed dictionaries that will appear. 

OFFICESUITE PREMIUM FEATURES 

Some advanced editing features are available in the Premium version of OfficeSuite only. 

 Export PDF to Word 

 Open Office format support 

 Format Painter 

 Save with password 

 Camera picture insertion 

 PDF to Word export 

THE SPREADSHEET EDITOR IN OFFICESUITE 

OfficeSuite allows you to open, create and edits Microsoft® Office XLS, XLSX, XLSM files, as 
well as CSV and Open Office ODS files.  

VIEWING AND NAVIGATION 

For easy browsing and navigation OfficeSuite offers some on-screen controls.  

 Changing of spreadsheets - as in Microsoft Excel, OfficeSuite supports different tabs 
for each spreadsheet. To switch to a spreadsheet, just tap on its tab at the bottom of 

the screen. You can also go to the View tab and tap on the Sheets toolbar 
button. A list of the available sheets will appear. 

http://www.mobisystems.com/mobile/android/category/dictionaries/


 
 

 

 

 Charts- Charts are embedded in the spreadsheets. To access the charts tap on the 

Charts button under the View tab  

 Zoom - You can select the most convenient zoom value from the Zoom button 
under the View tab. 

To revert to the original view tap on Zoom to normal .  

 Find & Replace - To find a word or phrase, tap on the Find & Replace button 
under the View tab. You can select different search options - Case sensitive, Match 
entire cell or Search in results of formulas. 

 Changing row height and/or column width - You can change the row height or column 
width by tapping and holding on the row/column boundary. Slide the boundary 
left/right or up/down. A thin black line will indicate the new boundary position.  

 Adding borders - By using predefined border styles, you can add a border around cells 

or ranges of cells. To add a border select the cell(s) and tap on the Cell borders 
button under the Format tab.  

 Grid lines - You can hide the grid lines in the sheet if the design of your sheet requires 

it. The Hide grid lines options is available under the View tab  
 Freeze - You can freeze rows and /or columns to make them visible all the time while 

you scroll in a sheet. To freeze a row or column select it and tap on the Freeze  
button under the View tab. To unfreeze rows/columns tap on Unfreeze.  

 Go to - To go to a particular cell use the Go to button and enter the cell 
coordinates in the "Go to cell" dialog. The Go to button is available under both the 
View and the Home tabs . 

Hyperlinks 

You can set hyperlinks to web addresses within a sheet. To do that go to Insert tab and tap 

on Hyperlink button and type in the URL to which you want to link. To follow the 

hyperlink tap on it and then follow the web address.  

 

 



 
 

 

 

Working with files  

You can create a new file by tapping on the New button under the File tab. OfficeSuite 

also offers templates of different types of documents which you can access from the 

Templates button. To open an existing file choose Open - from the File tab or go 

to the OfficeSuite browser and tap on the file. To open recently viewed files tap on Open 

recent - or go to the Side bar and tap on the Recent files option.  

When you save a file you can save it to the internal storage, to the SD card, to a remote 
account or in another file format.  

To save a file tap on the File tab and then on the Save  button. You will be prompted to 
choose a format from the available formats as well as set the file name and choose the save 
location. You can save files in the format they are originally saved or you can choose a 

preferred format. To change the format of an existing file tap on the Save as  button 
under the File tab and select the desired format. 

OfficeSuite allows you to change the file name from the OfficeSuite file browser. To do that 
long hold on the file and choose Rename from the popup menu. In the next dialog enter the 
name you want to use.  

To delete a single file or a multitude of files you can long hold on the file and choose Delete 
from the context menu or check the checkbox next to the file(s) and tap on the delete 
button on the toolbar  

If you want to save files so they cannot be modified you can do that through the Export to 

PDF feature located under the File tab. 

FILE SECURITY 

You can use passwords to stop other people from opening or modifying your files. To protect 

your files go to the File tab and tap on the Protect button. Enter a password in the 

Protect dialog. You will need this password the next time you open the document. To 

remove a password tap on the Protect button and delete the password you have set. Please 

note that if you forget your password OfficeSuite cannot retrieve it for you.  

 



 
 

 

 

PRINTING AND SHARING 

Printing 

In OfficeSuite you can print files over a wireless printer directly from the device. The print 

option is available under the File tab. To print a document tap on the Print button. The 

print preview screen will open allow you to check how the printed workbook will look. You 

can change the page settings from the Page settings option and then proceed to printing by 

selecting the printer you want to use. To add a new printer follow the instructions under 

"Add printer".  

SHARING 

OfficeSuite gives you the opportunity to share your files through a number of cloud services 

such as: Google Drive, Dropbox, Box, SugarSync and OneDrive. You can upload a file to a 

Remote account through Copy/Cut and Paste. To do that check the checkbox next to the file 

in the OfficeSuite file browser and choose Copy or Cut from the toolbar. Go to 

Side bar->Remote files and add your remote account. Once you are in the remote account 

you can paste the file from Edit -> Paste.  

You can also send files as email attachments or via Wi-Fi Direct from the OfficeSuite file 

browser. Check the checkbox next to the file to select it and tap on the Share button 
from the toolbar. Choose the file sharing option you want to use.  

EDITING SPREADSHEETS 

OfficeSuite allows you to modify cells, columns, rows, their formatting and contents, as well 
as to insert objects in spreadsheets and workbooks. 

To select multiple cells, hold the first cell and drag until you mark the whole desired area. 

OfficeSuite allows you to cut, copy and paste cells or selections to other places in the current 
document, other documents or external applications on your device. To do so: 

1. Select the cell(s). 

2. A popup toolbar will appear that will allow you to Cut or Copy the 
selection.  



 
 

 

 

3. Go to the place where you want to paste the text and select Paste from the 
popup toolbar.  

The Copy, Cut and Paste options are available from the Home tab as well.  

Undo / Redo 

In OfficeSuite you are able to undo and redo the last performed operations. To do so, use 

the undo or redo icons from the action bar. 

Inserting Objects 

OfficeSuite allows you to insert functions, rows/columns, images, charts and hyperlinks and 
to edit them.  

 To insert a function go to the Formula tab and select the cell where you want to use 

the function. Tap on Insert function and choose the function you want from 

the list. The button is also available at the top of the sheet. For easier access 
the functions are also grouped according to category in the Formulas toolbar :  

 
Financial  

 
Logical  

 
Text  

 
Date & Time  

 
Reference  

 
Math  

 To insert a row - select a row and tap on the Row above  button under 
theInsert tab. A new row will be inserted above the selected one . 

 To insert a column - - select a column and tap on the Column left button under 
theInsert tab. A new column will be inserted left of the selected one.  



 
 

 

 

 To insert a worksheet - tap on the new sheet button available next to the last 
sheet on the bottom toolbar. A new sheet will be inserted. To delete, rename or hide 
a sheet tap on the sheet name at the bottom of the screen and choose the option 
you want from the popup toolbar.  

 To insert a chart - go to the sheet where you want to place the chart and tap on the 

Chart button. Select chart type, range and properties.  

 To insert a chart in a separate sheet- Tap on the Chart in a new sheet button  

 Picture - select this menu option and you will be allowed to choose a picture to 
be included. Hold the image and move it to the position where you want it to appear. 
You can resize the image by tapping on any of the green dots that mark the image 
frame and then dragging to the desired size. To rotate the image, make sure it is 
selected, tap on the rotation icon that appears at the bottom right hand side of the 
image and rotate to the desired angle. You can also take a picture with the device 

camera and insert it directly into the sheet. To do that use the Camera picture 
button under the Insert.  

 To insert a comment - - select the cell to which the comment is related and tap on 

the Comment button .  

Formatting 

You can access to the most frequently used font and cell formatting options such as font size 
and type, bold, italic, underline, cell alignment, and font color through the Home tab in the 
spreadsheets module. The highlighted toolbar icons show the formatting currently applied 
to the selected cell(s). You can format selected cell(s) by tapping the desired toolbar icons.  

For more advanced formatting you can use the Format tab 

 Cells - the Format tab offers the options to modify the type of the cell, as well as to 
set up cell font, border and alignment. To clear the cell contents and remove all cell 

formatting you can use the Clear contents and Clear formats button 
under the Format tab 

 Rows - use the Hide rows Unhide rows buttons to hide and unhide rows  

 Columns - use the Hide columns Unhide columns buttons to hide and 
unhide columns. You can also change the column width to fit the cell contents using 

the Auto-fit columns  



 
 

 

 

 Rename sheet - use this button to modify a sheet's name 

In OfficeSuite you can also highlight important cells, emphasize values and visualize data 

based on criteria through the Conditional formatting button under the Format tab.  

OFFICESUITE PREMIUM 

Some advanced features are available in OfficeSuite Premium version only as in-app 
payment subscription. The premium features are: 

 Export to PDF 
 Print 
 Open Office format support 
 Save with password 
 Camera picture insertion 
 Insert Filter 
 Insert Conditional Formatting 
 Define Name 
 Export picture from file (Save Picture)  
 Edit Charts 
 Save as CSV 
 PDF to Excel export 

THE PRESENTATION EDITOR IN OFFICESUITE 

VIEWING AND NAVIGATION 

 Changing slides - You can easily swipe between the different slides.  
 Go to slide - To go to a particular slide go to the View tab and tap on the Go to slide 

button. Select the slide would like to open. 
 Slideshow- To start a slideshow, go to the Home tab and select and tap on the Start 

slide show  button. You can set different transitions (effects) when you move 
from one slide to the next during a presentation. To set transitions go to the Format 

tab and tap on the Transitions  button. Choose the transition you want to use 
and it will be applied to your presentation. To exit the transitions tap on the close

 button. You can choose between manual and automatic mode; you can run 
the slideshow in loop mode and you can use shape animations. These options are 
available under the Slide show tab. To stop the slideshow, press the square icon on 
the top left-hand corner of the screen.  



 
 

 

 

 Notes - To view the notes for each slide, hold on the Notes separator at the bottom 
of the screen and swipe upwards. 

 Find - To find a word or phrase go to the Home tab and tap on the Find  button. 
Type in the text in the bar that will appear.  

 Zoom - go to the View tab and tap on the 100% Zoom  button dialog will open 
from which you can select the desired zoom level. The supported zoom values are 
25%, 50%, 75% and 100%. You can use the Fit and Fit width buttons to auto fit a slide 
or expand it to the size of the screen.  

 Full Screen - allows you to use the whole screen of your phone as a work area. To 

switch to Full Screen, go to the Full screen  button under View tab. To exit Full 
Screen, tap on the standard device back button.  

Working with presentations  

You can create a new presentation by tapping on the New button under the File tab. 

After you start a new presentation or open an existing one you can add new slides through 

the New slide button.  

OfficeSuite also offers templates of different types of presentations which you can access 

from the Templates button. 

To open an existing file choose Open - from the File tab or go to the OfficeSuite 

browser and tap on the presentation. To open recently viewed files tap on Open recent 

- or go to the Sliding menu and tap on the Recent files option.  

When you save a file you can save it to the internal storage, to the SD card, to a remote 
account or in another file format.  

To save a file tap on the File tab and then on the Save  button. You will be prompted to 
choose a format from the available formats as well as set the file name and choose the save 
location. You can save files in the same format they are originally in or you can choose a 

preferred format. To change the format of an existing file tap on the Save as  button 
under the File tab. 



 
 

 

 

OfficeSuite allows you to change the name of a presentation from the OfficeSuite file 
browser. To do that long hold on the presentation and choose Rename from the popup 
menu. In the next dialog enter the name you want to use.  

You can delete files from the file browser as well. To delete a single file or a multitude of files 
you can long hold on the file and choose Delete from the context menu or check the 
checkbox next to the file(s) and choose delete from the toolbar  

If you want to save files so they cannot be modified you can do that through the Export to 

PDF feature located under the File tab. 

FILE SECURITY 

You can use passwords to stop other people from opening or modifying your files. To protect 

your files go to the File tab and tap on the Protect button. Enter a password in the 

Protect dialog. You will need this password the next time you open the document. To 

remove a password tap on the Protect button and delete the password you have set. Please 

note that if you forget your password OfficeSuite cannot retrieve it for you.  

PRINTING AND SHARING 

Printing 

In OfficeSuite you can print files over a wireless printer directly from the device. The print 

option is available under the File tab. To print a document tap on the Print button. To 

add a new printer follow the instructions under "Add printer".  

Sharing 

OfficeSuite gives you the opportunity to share your files through a number of cloud services 

such as: Google Drive, Dropbox, Box, SugarSync and OneDrive. You can upload a file to a 

Remote account through Copy/Cut and Paste. To do that check the checkbox next to the file 

in the OfficeSuite file browser and choose Copy or Cut from the toolbar. Go to 

Side bar->Remote files and add your remote account. Once you are in the remote account 

you can paste the file from Edit -> Paste.  

You can also send files as email attachments or via Wi-Fi Direct from the OfficeSuite file 

browser. Check the checkbox next to the file to select it and tap on the Share button 
from the toolbar. Choose the file sharing option you want to use.  



 
 

 

 

OUTLINE VIEW  

The Outline view shows the slide text in outline form. To access the Outline view, go to the 

View tab and tap on the Outline view button. To return to normal view tap on the 

Slide view button.  

EDITING SLIDES 

Slide Formatting 

You can access to the most frequently used font and paragraph formatting options such as 
font size and type, bold, italic, underline, paragraph alignment and indent, and font color 
through the Home tab in the document module. The highlighted toolbar icons show the 
formatting currently applied to the selected text. You can format selected text by tapping 
the desired toolbar icons.  

Slide Management 

Through the Format menu you can manage the slides in the current presentation. You are 
able to: 

 Reorder slides - Select the corresponding menu item and reorganize the slides by 
dragging and dropping them to their new positions. 

 Duplicate slide - Duplicates the current slide. 

 Delete slide - The currently active slide is deleted. 

 Change transition - You can change the transition between slides in slideshows. You 
are able to select from a list of transitions. You can further customize the additional 
properties for each transition, in order to add personal touch to the slide 
arrangement. 

Inserting Objects 

With the Insert tab you are able to insert objects in slides or to insert new slides.  

 Insert slide - A new slide is inserted before the current one. 

 Insert picture - You will be allowed to select a picture via external software. When 
the image is inserted you can:  

o drag it to the desired position 

o resize it by holding on one of the blue dots from the frame and dragging in the 
desired direction 

o rotate it to an angle of your choice  

o or delete it by selecting the delete icon at the top left hand corner of the screen 

 Camera picture - You can take a picture with the device camera and insert it into the 
slide. 



 
 

 

 

 Insert text - A new text box is inserted in the current slide where you can enter text. 
Move the text box to the desired position by tapping on it and dragging where you 
want to place it. 

 Shapes - You can also insert shapes. Available shapes include lines, basic geometric 
shapes, arrows, stars, banners, and callouts.  

Modifying Slides 

Working with Text 

To modify the text of a slide, simply tap in its text box and then to the position you want to 
edit. Type in or delete the text as you wish. 

To delete a text box, tap on the box to select it and then press the delete icon at the top left 
hand corner of the text box frame. 

To rotate a text box, tap and hold the rotate icon at the top right hand corner of the text box 
frame and then rotate to the desired angle. 

Outline view  

The Outline view shows the slide text in outline form. To access the Outline view, go to the 

View tab and tap on the Outline view button. To return to normal view tap on the 

Slide view button.  

Slide notes 

OfficeSuite also allows you to add or modify notes to each slide. To do so, navigate to the 
desired slide while you are in Slide view. The footer part of the screen is dedicated to slide 
notes. Tap in this area to start editing your notes. 

PREMIUM FEATURES  

Some advanced editing features are available only in OfficeSuite Premium as in-app 
subscription. The premium features are: 

 Export to PDF 

 Print 

 Open Office format support 

 Save with password 

 Camera picture insertion 

 Edit transitions 



 
 

 

 

OFFICESUITE PDF MODULE 

You can zoom in and out a PDF file through the Zoom menu. You can also select the desired 
zoom value - 25%, 50%, 75% and 100%, Fit width or Fit (for auto fit) - though the Zoom 

button in the Home tab . Alternatively you can use pinch-to-zoom. 

To find text in the current document, press the button from the Home tab.  

PAGE NAVIGATION 

There are a couple of options available for page navigation: 

1. You can swipe flip through the pages.  
2. If you want to go to a particular page you can to that through the Go to page button 

in the Home tab. Use the arrow buttons to choose a page number or enter it from the 
keyboard.  

CREATING PDF DOCUMENTS 

You can create new PDF files with another one of our apps called QuickPDF Sacanner (part of 
OfficeSuite Premium). QuickPDF Scanner allows you to edit PDFs by adding, deleting and 
reordering pages.  

ADDITIONAL FEATURES 

Some features in the PDF module are available only in OfficeSuite Premium as an add-on 
subscription. The premium features, you can take advantage of if you upgrade, are: 

 Export of PDF to Word, Excel and ePub 
 Quick PDF Scanner add-on 

PROTECTING PDF FILES 

You can change the document security, visualize and validate the digital signatures available 
in the document as well as certify, sign or time-stamp the document through Protect tab.  

PDF DOCUMENT SECURITY 

The Protect tab displays the current security settings of the document and allows you to 
change them. A PDF document is secured with passwords. The contents of a secured PDF 
document is encrypted and can be visualized and changed only if the correct password is 
supplied. The PDF security settings include also a set of permissions which are applied when 
restricted access to the document is provided. 



 
 

 

 

The PDF documents support two passwords as follows: 

 Document open password. When this password is supplied the document is opened 
in restricted mode and the specified permissions are applied. 

 Full access password. This password provides full access to the document and allows 
all visualization and modification functions. Note: the functions available on a 
particular document may be restricted by other protection features, e.g. by the 
digital signatures available in the document. 

If the document open password is empty the document is opened in restricted mode 
without requesting a password. If the full access password is empty the document open 
password provides full access to the document. 

The document permissions consist of three sets of actions related to printing, changing the 
document contents and extraction of text and other data from the document. The 
permissions are applicable if a separate full access password is available and the document is 
opened in restricted mode. 

The document security settings include an option to disable encryption of the document 
metadata. Leaving the metadata unencrypted allows finding the document by certain search 
engines based on the metadata contents without the need of knowing the document 
passwords 

The Protect dialog also allows you to select the encryption algorithm and key size out of the 
standard options supported by the PDF document format. 

WORKING WITH DIGITAL SIGNATURES 

The digital signatures provide additional protection functions that are aimed to ensure the 
integrity and timeliness of the documents. The physical content of the document that is 
signed can not be changed without invalidating the signature. If signature permissions allow, 
a signed document can still be modified using an incremental update but these 
modifications are clearly identifiable and the original document content (the document state 
just before the signing) can always be restored. Thus the signed document content 
represents a document revision. The document may contain multiple consecutive revisions 
each protected by its own signature. In addition to the integrity protection it is also possible 
to attest that certain document revision existed before a specified time. This is done by 
embedding a digital time-stamp in the document which is a special type of digital signature 
created by a trusted time-stamp authority accessible through the network. 

Validation of digital signatures and addition of new signatures to a PDF document requires 
access to the corresponding certificates and private keys which should be located on the 
mobile device. On Android system the certificates and private keys are stored in the so 
called Trusted Credential Storage. Android version 4.0 or later is required to perform 
signatures validation and addition with the OfficeSuite PDF Reader. 

For more information on digital signatures please click here. 

http://www.mobisystems.com/digital-signatures.html


 
 

 

 

Displaying and Validating Digital Signatures 

The document signatures are displayed in the Signatures dialog. The dialog is opened by the 
Signatures item of the Protect menu (on small screen devices) or by the Signatures tab of the 
left tab bar (on large screen devices). The Signatures dialog may also be opened from the 
overflow menu of the Signatures status bar at the bottom of the screen. If none of these 
items is available then the document does not contain digital signatures 

The Signatures dialog displays all available signatures in the order they are added in the 
document (the oldest at the top of the dialog). The signatures are presented with their most 
important attributes (type, status, signer, signing time, etc.). Each signature item has an 
overflow menu that allows you to see the signature details, open the document revision 
related to the signature or go to the corresponding signature field in the document if it is 
visible. If you choose to display a document revision related to some signature the 
OfficeSuite PDF Reader opens it in read-only mode with limited functions available. However 
it allows you to save the revision as a new PDF file which can be later on opened in read-
write mode with all functions enabled. 

The embedded digital signatures are not validated by default since the validation may take 
significant time. The validation may be started by pressing the Validate button in the 
Signatures dialog. The signatures validation is a comprehensive procedure based on the 
standards and recommendations of IETF and ETSI. It includes the following validation steps 
for each signature: 

1. Validate the signing digest including decoding the digest with the signing certificate 
public key, calculating a new digest from the signed content and comparing the 
decoded and the newly derived digests. 

2. Validate the signing certificate (see details below). 

3. Validate the embedded time-stamp (if any) including steps 1 and 2 for the time-
stamp digest and the time-stamp certificate. 

4. Validate the modifications of the document after it was signed to ensure that they 
are allowed by the signature permissions. 

The Signatures Details dialog displays the detailed information for the signature and the 
results of the above validation steps if the validation was performed. 

Signing Certificate Validation 

The validation of the signing certificate is the most complicated part of the signature 
validation process. The certificates are usually issued by Certificate Authorities and are 
signed with the CA private key. In order to validate the certificate signature it is necessary to 
have the certificate of the CA. Often the CA is an intermediate authority and its certificate is 
also signed by another CA. Thus it is necessary to build the complete certificate chain up to 
the root CA which has a self-signed certificate. The signing certificate including the public key 
is embedded in the signature data in the PDF document. However the CA certificates may or 
may not be available in the signature data. If the CA certificates are not available in the 



 
 

 

 

document they should be present in the Android Trusted Credential Storage (TCS). The root 
certificate should always be found in TCS (even if it is available in the document) in order to 
ensure that the whole chain can be trusted. Android has pre-installed many CA certificates in 
TCS which belong to global security providers. These certificates are trusted by default. You 
are allowed to add new CA certificates to TCS (see the Add certificates and private keys to 
the Trusted Credential Storage section) but you should do this only for certificates that you 
really trust. It is also possible to deny some of the pre-installed CA certificates if you do not 
trust them (see Android help for details). 

When the certificate chain is built each certificate in the chain is validated based on its 
attributes. The validation includes checking of certificate purpose, time validity, extensions, 
constraints, etc. In addition a special check is performed of the certificate revocation status. 
The Certificate Authority that issued the certificate may revoke it if the certificate private key 
is compromised for some reason. The CAs provide the so called Certificate Revocation Lists 
(CRL) or other online interfaces to check for revoked certificates. The revocation verification 
information may be embedded in the signature data. If it is not available or it is expired the 
revocation check needs to be performed online. Therefore, in the general case, the mobile 
device must have an Internet connection in order to accomplish the revocation check. 

The certificate details as well as the results of the certificate validation are displayed in the 
Certificate Details dialog. This dialog is opened if you follow the links from the certificate 
chain displayed in the Signatures Details dialog. The dialog contains a Trust button which is 
enabled if the certificate belongs to a CA. This button allows you to add certificates extracted 
from the signature data in the document to the Trusted Credential Storage. In particular this 
function can be used to add the certificate chain root to TCS if it is not there but you trust it. 
This would be necessary to complete the signature validation without errors. 

Time Validation of Digital Signatures 

Some elements of the digital signatures (e.g. the certificates and the certificates revocation 
verification information) are valid within a specified time range. Therefore the validity of the 
whole digital signature depends on the moment of time for which the validity is checked. 
The OfficeSuite PDF Reader follows the ETSI recommendations for determining the validity 
check time. In general the validation of the signatures is made related to the current time. In 
this case the certificates verification information stored in the document is irrelevant and 
fresh verification information is obtained from the certificate issuer. However, if the 
document contains time-stamp signatures or time-stamps embedded in other types of 
signatures these time-stamps provide secure time anchors which allow the PDF Reader to 
perform the validation at earlier time moments. In this case PDF Reader tries to use the 
verification information stored in the document in case that it is protected by a time-stamp. 
In more details the validation procedure is the following:  

1. The "latest" document time-stamp and all later signatures are validated at the 
current time with verification information collected at the current time. If the 
document does not contain time-stamps all signatures are validated at the current 
time. 



 
 

 

 

2. The "inner" document signatures (including "inner" time-stamps) are validated at the 
time of the previous valid document time-stamp that encompasses the necessary 
verification information. If the verification information is not available or is invalid 
the validation is done at the current time as described above. 

In fact the document time-stamps protect the elements with restricted time validity from 
expiration. In order to provide such protection a particular time-stamp should also be valid. 
The Certificate Details dialog informs you if the corresponding certificate has the necessary 
verification information stored in the document and protected by a valid time-stamp. 
Protection of the time-dependent signature elements with time-stamps allows long-term 
validity of the PDF digital signatures. See the Ensure long-term validity of the digital 
signatures section for details how to ensure the long-term validity of the signatures. 

Managing Signature Profiles 

Creating and adding new digital signatures to a PDF document requires setting of several 
parameters including selection of a client certificate with private key, setting permissions, 
providing a time-stamp server URL, etc. Often the same parameters are used when creating 
multiple signatures. In order to make the signing faster and simpler the OfficeSuite PDF 
Reader allows you to create in advance signature profiles with the most frequently used 
combinations of parameters. A signature profile may be afterwards applied to create a new 
signatures without the necessity to enter all parameters. 

The Signature Profiles dialog is opened by the Profiles item of the Protect menu. The dialog 
lists the available profiles grouped by signature type ("Certify", "Sign" and "Timestamp") and 
allows you to edit, copy, rename or delete existing profiles as well as add new profiles of the 
corresponding type. The profiles are uniquely identified by type and name. The parameters 
of the profiles from the different types match the parameters available when adding a 
signature from the corresponding type (excluding the parameters that are dependent on the 
particular document and may not be predefined in a profile). See the Adding signatures to a 
document section for details about the different parameters available. 

Adding Signatures to a Document 

The OfficeSuite PDF Reader provides three items in the Protect menu (Certify, Sign and 
Timestamp) to add the corresponding signature type to the current document. When any of 
these items is selected a dialog is opened which allows you to select a pre-defined signature 
profile of the selected type. Press the Show details button to see the detailed parameter 
values and change them if necessary. 

The detailed parameters for the different signature type are described below. Not all 
parameters are available for each signature type. 

 Certificate (required for Certify and Sign types). Used to select a client certificate with 
private key to sign the document content digest. 



 
 

 

 

 Digest algorithm (required). Used to select the digest algorithm that will be used to 
calculate the document content digest.  

 Reason (optional). Used to provide the reason for signing the document. 

 Signer's name (optional). Used to provide the name of the person or entity signing 
the document. 

 Location (optional). Used to provide the location of signing. 

 Contact information (optional). Used to provide contact information of the person or 
entity signing the document. 

 Add timestamp and Timestamp server URL (required for Timestamp type). Used to 
add a time-stamp to the signature. The time-stamp server with the specified URL 
should conform to IETF standard RFC 3161 Time-Stamp Protocol (TSP). 

 Add verification info (optional). Used to add the certificate revocation verification 
information to the signature data. 

 Allowed changes after signing (required for Certify type). Used to select what 
changes are allowed in the certified document. 

 Lock document after signing (optional). Used to specify that the document will be 
locked after signing, i.e. no further modifications will be allowed. 

 Lock fields after signing (optional). Used to specify action for locking of PDF form 
fields in the signed document. The available options are "None" (no fields will be 
locked), "All" (all fields will be locked), "Include" (only selected fields will be locked) 
and "Exclude" (all except the selected fields will be locked). 

 Selected fields (optional). Used to select the fields the will be included to or excluded 
from locking if "Include" or "Exclude" action is selected in the previous parameter. 

Ensure Long-term Validity of the Digital Signatures 

As described in the Time validation of digital signatures section certain elements of a digital 
signature have restricted time validity. If they expire the whole signature will be invalidated. 
In order to avoid this, all necessary verification information should be included in the 
signature data and it should be protected by a time-stamp. In more details, the following 
actions should be accomplished when adding a new signature: 

1. The complete chain of the signing certificate should be added to the document. This 
is done automatically by the OfficeSuite PDF Reader. 

2. The certificate revocation verification information for all certificates should be added 
to the document. In order to do this you should check the Add verification info 
parameter. Note that this action can increase significantly the signature data and the 
signed document respectively. 

3. Add an embedded time-stamp to the signature or a separate time-stamp signature 
immediately after the signing. 

The above procedure ensures the validity of the added signature until the protective time-
stamp is valid. 

 



 
 

 

 

Adding Certificates and Private Keys to the Trusted Credential Storage 

The Trusted Credential Storage (TCS) is an Android secure store for CA certificates and client 
certificates with private keys. The options for TCS management can be found in the Android 
Security Settings under the Credential Storage heading (the exact location and option names 
may vary depending on the Android version). The Trusted Credential Storage contains many 
pre-installed certificates which belong to global security providers. The new certificates are 
installed using the Install from internal storage option. When this option is selected a file 
browser window is opened which allows you to choose the files containing the certificates to 
be installed. (Some Android versions may require that the files are located in the root of the 
device internal storage or external SD card.) The following types of certificates can be added 
to TCS: 

 Certificates of Certificate Authorities. The acceptable files have .crt or .cer extension 
and should be internally marked as CA certificates. 

 Client certificates with private keys. The acceptable files have .pkx or .p12 extension 
and should contain a private key in addition to the client certificate. The files may 
optionally contain CA certificates which will be also installed. 

The installed CA certificates can be reviewed using the Trusted credentials option of the 
Android Security Settings. Note that the client certificates are not shown in the Trusted 
Credentials view. However if the installation is successful they will be available in the 
corresponding signature dialogs of the OfficeSuite PDF Reader. 

Note: When you try to add a new certificate to the Trusted Credential Storage the Android 
system may ask you to set a secure screen lock (e.g. pattern, PIN or password) if such screen 
lock is not already set. This is necessary to ensure that your certificates have enough 
protection if your device is lost or physically accessed without your permission. 

Troubleshooting the Digital Signatures Handling 

Validation of the digital signatures and addition of new signatures involve complicated 
procedures which may fail due to different reasons. If you experience errors during signature 
validation or addition please make sure that the following conditions are met: 

 The mobile device has an Internet connection. 
 The correct date and time are set. 
 The necessary CA certificates are available in the Android Trusted Credential Storage. 
 The time-stamp server URL (when trying to add a time-stamp) is valid. 
 The document permissions allow the corresponding operation. 

OFFICESUITE EMAIL VIEWER 

VIEWING EML FILES 

OfficeSuite is the only mobile office that supports the EML file format, which is the Outlook 
Express Saved Mail Messages file format. OfficeSuite handles EML file format in two 



 
 

 

 

different ways - either directly from your email client if you try to open an EML file or, if you 
have such file saved on your device, you can access it via the file browser. 

OfficeSuite will open the EML file as if you are working with a regular email client. You are 
able to view the email message, details about the sender and receiver, subject, date and 
time. If there are attachments in the EML file, you will see them at the bottom of the email 
and will be able to open or save them.  

 


